Toshiba new screen cable showing artifacts

Discussion in 'Laptop Hardware' started by Aristeidisp, Aug 8, 2018.

  1. Aristeidisp

    Aristeidisp

    Joined:
    Aug 8, 2018
    Messages:
    1
    Likes Received:
    0
    Hello everyone,
    I am facing a problem with my Toshiba Satellite C50B-14H.

    Suddenly when the laptop's top cover was raised above the half-open position the display would go dark.
    I opened the laptop and the screen cable appeared to be damaged near the right hinge. Even with the top cover lowered if I applied pressure at the specific point the display would turn off.

    I replaced the screen cable with an identical new one (appropriately placed). As a result, when the top cover was more than half-opened the display was on but had many vertical red lines appearing. It appears that the new cable was also pressured by the hinge even though there are plastic "guides" to position the cable correctly. I decided to "unhook" the cable from these plastic "guides" near the hinge so that the cable would not be strained or pressured and be a bit more free. This seemed to work.

    The next day when I turned on the laptop again, the vertical red lines reappeared even more so. I can't even see the screen now.

    Does anyone have any thoughts / suggestions as to how I may proceed fixing this?

    Thank you for your time.

    PS. External monitor works fine, no apparent other GPU issues.
     
    Aristeidisp, Aug 8, 2018
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.