Make the Storage Expansion SDHC slot act like normal SDHC

Discussion in 'Linux' started by sideways, Aug 31, 2008.

  1. sideways

    sideways

    Joined:
    Aug 21, 2008
    Messages:
    172
    Likes Received:
    0
    In the 120GB Linux models it seems a bit pointless having the storage expansion feature for sdhc cards, especially if they are only a few GB. This slot is nicer to use than the one on the rhs because it conceals the sdhc card without any protusion, so I wanted to use this slot as a "normal' sdhc adapter (Like in the WindowsXP version)

    It's pretty simple, edit /etc/macles.cfg and put a hash symbol '#' in front of the line:

    EXPUDI=pci0000:00/0000:00:1c.3/0000:04

    so it becomes

    #EXPUDI=pci0000:00/0000:00:1c.3/0000:04

    To edit the file, open a terminal with alt+f2, 'terminal', and type
    Code:
    sudo mousepad /etc/macles.cfg
    Now reboot.

    The only problem is that the file window doesn't open automatically when you insert the card, you need to go to Files->My Files in the standard Acer desktop, or just double-click or right-click on the sdhc icon in the xfce desktop and select 'Open'
    EDIT: After experimenting a little I found that if I just change the '3' to '2' in the above line rather than adding the '#' at the beginning then the File Window does appear upon insertion in both SD slots - so perhaps use that for the time-being (This macles.cfg file is unique to the Acer and I don't understand how to correctly edit it - I'm just making educated guesses)

    Always unmount the sdhc card before removing by right clicking on the icon in the file manager (or on the desktop) and selecting 'Unmount Volume', this will ensure files are written safely.
     
    sideways, Aug 31, 2008
    #1
    1. Advertisements

  2. sideways

    a1m1

    Joined:
    Aug 26, 2008
    Messages:
    5
    Likes Received:
    0
    I've got the 8G model, but would like to use the same trick... thing is I have no /etc/macles.cfg file. Is the linpus distro different for the 120G model?

    (i grepped /etc for anything with 'EXPUDI', no joy)
     
    a1m1, Sep 1, 2008
    #2
    1. Advertisements

  3. sideways

    SuzuKube

    Joined:
    Aug 20, 2008
    Messages:
    53
    Likes Received:
    0
    You can just.... Display thunar in "Advanced' Mode :) It will do the same :)
     
    SuzuKube, Sep 1, 2008
    #3
  4. sideways

    PhilthyPhil

    Joined:
    Aug 9, 2008
    Messages:
    5
    Likes Received:
    0
    On the 8GB model that I have, if you place the thunar in "Advanced mode" setting it will not stick after a reboot.

    Has anyone found a way to make the setting stick :?:
     
    PhilthyPhil, Sep 2, 2008
    #4
  5. sideways

    TheTilde

    Joined:
    Feb 16, 2009
    Messages:
    49
    Likes Received:
    0
    strange... I have the 8G model too, and I have a /etc/macles.cfg file...

    TheTilde
     
    TheTilde, Feb 27, 2009
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.