GPU not working as well as it used to

Discussion in 'Laptop Hardware' started by kendclark, Dec 25, 2022.

  1. kendclark

    kendclark

    Joined:
    Dec 25, 2022
    Messages:
    1
    Likes Received:
    0
    I have an Aspire V17 Nitro with a GTX 1060 GPU. I also have an Oculus Rift (gen 2 I think).

    I used to be able to play pretty much any VR game I tried, with no problem.

    I have not played much for a couple years, but recently tried out Divinity Original Sin 2 (not VR). I noticed it was having serious performance problems, and found the system was not using the nVidia card, even when the laptop was plugged in. I worked through that issue, it seems there was something wrong with the driver. I had to uninstall the driver and found that I could not install the standard nVidia driver that handles all cards, I had to track down the device specific driver and install that. Once I did that I was able to re-install the GeForce Experience software, and everything seems ok (Divinity now runs acceptably well).

    Except that I find I can no longer run anything in VR. It cycles for about 15 seconds of normal VR followed by about 15 seconds of nearly frozen screen and various other artifacts that appear to be related to the GPU. This goes on indefinitely until I give up. I have tried multiple games including a game I know used to run just fine. It is as if it is choosing to not use the GeForce GPU periodically.

    Any ideas what could be wrong or what I can do to get VR working again?

    Thanks!
     
    kendclark, Dec 25, 2022
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.