Acer 5734z freezes at acer logo

Discussion in 'Acer' started by Osvaldo Nadal, Aug 29, 2015.

  1. Osvaldo Nadal

    Osvaldo Nadal

    Joined:
    Aug 29, 2015
    Messages:
    1
    Likes Received:
    0
    Hi everyone, I bought an used Acer 5734z that freezes on Acer logo. I changed ram, cpu, power charger,......everthing. I removed cd rom, hdd, wifi and nothing happened.
    Everytime it turns on, i tried to access to bios pressing F2 and itfreezes again.............I turn it on and I press Esc key and shows bios post and freezes again!!!......I decided to upgrade bios.......but when it starts the bios flashing process (obviously pressing fn+Esc before plug the power charger and turn it on) the notebook turns off and I cant turn on if i dont unplug the power charger.
    Suggestions? I tried using the latest bios, the first one, all software includded, only the .fd file.......is all the same......it turns off!!!
     
    Osvaldo Nadal, Aug 29, 2015
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.