Get the Linux desktop you always wanted in 10 easy steps!

Discussion in 'Linux' started by rjm, Sep 28, 2008.

  1. rjm

    rjm

    Joined:
    Jul 24, 2008
    Messages:
    345
    With this simple procedure, you can remove the standard Acer desktop and icons and replace them with a customizable wallpaper and your choice of desktop icons. All Acer pre-installed functionality is maintained. System settings are maintained after reboot.

    [attachment=0:1v2ti8dk]Screenshot-sm.png[/attachment:1v2ti8dk]

    It works, baby, my little Holy Grail of getting a normal and fully functional xfce desktop on the A1 has been obtained at long last! I have double checked everything by repeating it after a system restore.

    Open the terminal by pressing Alt-F2 and typing "terminal"...

    1. Edit xfce4-session.rc to change the Client0 line to point to xfdesktop rather than xfdesktopnew.


    Code:
    sudo mousepad /etc/xdg/xfce4-session/xfce4-session.rc
    
    replace xfdesktopnew with xfdesktop

    #Client0_Command=xfdesktopnew
    Client0_Command=xfdesktop
    Client0_PerScreen=False
    Client1_Command=xfwm4
    Client1_PerScreen=False
    Client2_Command=xfce4-panel
    Client2_PerScreen=False
    Client3_Command=/usr/share/search-bar/start-search_bar.sh
    Client3_PerScreen=False
    Client4_Command=xfcepost
    Client4_PerScreen=False


    2. Edit xfdesktop to launch xfdesktop-xfce instead of xfdesktop2.

    Code:
    sudo mousepad /usr/bin/xfdesktop
    
    replace xfdesktop2 with xfdesktop-xfce

    #!/bin/sh
    if [ -f /usr/bin/xfce-mcs-manager.new ];then
    sudo mv /usr/bin/xfce-mcs-manager.new /usr/bin/xfce-mcs-manager
    fi
    #/usr/bin/getnum.sh
    #/usr/bin/xfdesktop2 & >/dev/null 2>&1
    /usr/bin/xfdesktop-xfce & >/dev/null 2>&1
    sleep 5
    if [ -f /usr/bin/xfce-mcs-manager ];then
    sudo mv /usr/bin/xfce-mcs-manager /usr/bin/xfce-mcs-manager.new
    fi


    3. Disable the Acer search bar.

    Code:
    sudo mousepad /usr/share/search-bar/start-search_bar.sh
    place a # in front of all the lines

    #!/bin/sh
    #resolution=`xrandr |grep \*|awk '{print $1}'`
    #resolution=`xrandr |grep current|awk -F"current" '{print $2}'|awk -F"," '{print $1}'|sed 's/\ //g'`
    #
    #if [ $resolution = "1280x800" ];then
    # acer-search-desktop --x=650 --y=90 --width=490 --height=31
    #elif [ $resolution = "1024x600" ];then
    # acer-search-desktop --x=510 --y=65 --width=490 --height=31
    #else
    # acer-search-desktop
    #fi


    4. Move the xfce4 user configuration directories to backup locations.

    Code:
    mv ~/.config/xfce4 ~/.config/xfce4.old
    mv ~/.config/xfce4-session ~/.config/xfce4-session.old
    
    5. Reboot

    New xfce4 user configuration directories are automatically created.

    6. Let xfce manage the desktop, and enable your wallpaper

    Open the terminal by pressing Alt-F2 and typing "terminal"...

    Copy your wallpaper image to the /usr/share/xfce4/backdrops directory, {example for the picture originally in the Pictures directory}

    Code:
    sudo cp ~/Pictures/{filename.jpg} /usr/share/xfce4/backdrops/{filename.jpg}
    
    then bring up the desktop settings,

    Code:
    xfce-setting-show
    
    - click Desktop icon, tick "Allow xfce to manage the desktop".
    - select background wallpaper (click on the little icon next to the file path)

    {...you can stop here, the rest of this section and the remaining sections below just tidy things up...}

    - on Behaviour tab, tick "show desktop menu on right click"
    - reduce icon size to 48 and font size to 10 (adjust to taste)


    7. Edit the bottom taskbar by adding a start menu.

    Code:
    xfce4-panel -a
    
    - drag Xfce Menu item from the window to the left hand side of the taskbar
    - other icons can be added too, for various shortcuts and links
    - the "trash" icon apparently prevents USB devices from automounting, so avoid adding that one!

    8. Remove the system desktop icons by making a new file called xfdesktoprc in the .config/xfce4/desktop directory.

    Code:
    mousepad ~/.config/xfce4/desktop/xfdesktoprc
    and add the following text

    [file-icons]
    show-filesystem=false
    show-home=false
    show-trash=false


    now save the file and reboot

    9. Add your favorite icons to the desktop by copying the .desktop file from /usr/share/applications to ~/Desktop

    This is most conveniently done by opening File Manager (thunar) - View - View as advanced mode, navigating to /usr/share/applications and dragging the icons you want directly to the desktop. The icons can be repositioned on the desktop with the cursor.


    10. Clean up the xfce menu.

    Get rid of the useless links to hotmail, google maps, etc by moving or deleting the contents of the edesktop folder.

    Code:
    sudo mv /usr/share/applications/edesktop ~/Documents/edesktop
    
    the main part of the menu is generated automatically from the .desktop files, but some items can be edited from

    Code:
    xfce4-menueditor
    
    NOTES

    An equivalent route, one less step: leave xfce4-session.rc as is, but edit xfdesktopnew changing the word xfdesktop2 to xfdesktop-xfce. I didn't try that though.

    I have to say having a clean desktop and my own choice of desktop icons makes an gigantic difference to how I feel towards my A1. The problem with Acer desktop is twofold, first it's impersonal and dull, even though its practical and attractive enough in its way, second, it is a constant and unwelcome visual clutter around any open window. The latter is like background noise: you don't notice it until you turn it off. Then you realize just how annoying it was.

    Feel free to post your screenshots to this thread. Press Alt-F2 and type "gnome-screenshot --interactive" in the command line.
     
    rjm, Sep 28, 2008
    #1
    1. Advertising

  2. rjm

    jccguays

    Joined:
    Jul 28, 2008
    Messages:
    36
    Location:
    Spain
    Re: How to: get the Linpus XFCE desktop to stay after reboot

    Great, thanks for the methods to do it. It works

    When I can I will upload an image

    Best regards
     
    jccguays, Sep 28, 2008
    #2
    1. Advertising

  3. rjm

    rjm

    Joined:
    Jul 24, 2008
    Messages:
    345
    Re: How to: get the Linpus XFCE desktop to stay after reboot

    [contents folded into original post]
     
    rjm, Sep 29, 2008
    #3
  4. rjm

    Mako

    Joined:
    Sep 29, 2008
    Messages:
    8
    Re: How to: get the Linpus XFCE desktop to stay after reboot

    Hi guys, I've followed this guide and now I have the standard XFCE-Desktop showed at start.
    But I also have two issues:
    - Removable devices are not automounted when plugged (I don't know if it's panel fault...)
    - At each reboot I lose my desktop background
    FIXED: just make sure the wallpaper is in the default directory /usr/share/xfce4/backdrops/

    Someone has the same problem? Someone could help me, please?

    Mako'
     
    Mako, Sep 29, 2008
    #4
  5. rjm

    jccguays

    Joined:
    Jul 28, 2008
    Messages:
    36
    Location:
    Spain
    Re: How to: get the Linpus XFCE desktop to stay after reboot

    Hi, I had the same problems, but I found the solution (I think)

    1. Removable devices are mounted, buy you need to open advance view in Thunar to see them. In any case, I think that if you open a terminal you can navigate into them.

    2. To have the desktop background you need to copy the png file you want in the backdrops directory. Now I don't remember exactly where it's (I normally work with Windows), but if you try to change the default background, you'll see it.

    I expect this can help you.

    Best regards.
     
    jccguays, Sep 29, 2008
    #5
  6. rjm

    Mako

    Joined:
    Sep 29, 2008
    Messages:
    8
    Re: How to: get the Linpus XFCE desktop to stay after reboot

    Thanks jccguays.
    I also noticed that killing all Thunar process (killall Thunar in Terminal), and restart it (in standard mode) you will see all the removable devices.
    But that's not a very good solutions for me, I hope someone resolve this issue.
     
    Mako, Sep 29, 2008
    #6
  7. rjm

    Fuerst

    Joined:
    Sep 1, 2008
    Messages:
    102
    Re: How to: get the Linpus XFCE desktop to stay after reboot

    Hi friends,
    I have tried to follow the instructions and copy/paste commands. but it didn't work. after first command a second window opened up, warning me of danger involved in superuser activity. all other commands ha dno reaction

    any idea?
    thxs and cheers
    Christian
     
    Fuerst, Sep 29, 2008
    #7
  8. rjm

    Cesium

    Joined:
    Aug 18, 2008
    Messages:
    26
    Re: How to: get the Linpus XFCE desktop to stay after reboot

    Fuerst

    your picture files have to be copied into the backdrops folder.

    alt f2
    terminal
    su
    (enter your password)
    cd Pictures
    mv (your picture file and its extension) /usr/share/xfce4/backdrops/

    *note* there is a space between your file name and /usr/share etc....
    then go into your desktop manager and select the "backdrops" folder and it's local copy of your picture. It should stay on reboot now.

    RJM-
    thanks for figuring this out. I have no idea how you even started to do this. XFCE is definitely better than the original linpus desktop.
     
    Cesium, Sep 29, 2008
    #8
  9. rjm

    jccguays

    Joined:
    Jul 28, 2008
    Messages:
    36
    Location:
    Spain
    Re: How to: get the Linpus XFCE desktop to stay after reboot

    I've done and, by now, I'm happy. Anyway I have a little doubt.

    I have prepared the system to press the right bottom in the touchpad and I have the menu, but if I use a USB Mouse it don't. Hay anyone the same "silly" problem? I would like to know why, I don't mind, but......

    And a little thing, can anyone tell me how I can take a image of my desktop to paste here? :oops:

    Regards
     
    jccguays, Sep 30, 2008
    #9
  10. rjm

    rjm

    Joined:
    Jul 24, 2008
    Messages:
    345
    Re: How to: get the Linpus XFCE desktop to stay after reboot

    To take a desktop screenshot, execute the following command

    Code:
    gnome-screenshot
    or

    Code:
    gnome-screenshot --interactive
    *****

    I do not experience any problem with removable devices. The behaviour of my A1 is unchanged after the mod, namely if I hot-plug a USB memory stick the device is mounted automatically and Thunar is called automatically to view the contents of the device.

    Type "xfce-setting-show" to bring up the xfce settings manager, click on file manager, select the advanced tab, enable volume management should be ticked. Click on "configure" to bring up the removable drives and media menu, all 5 options under the Storage - removable storage should be ticked.

    *****

    The only thing I did note was that the "show-removable=true" tag in xfdesktoprc does not appear to do anything, I don't get a new desktop icon when I plug in a device.

    *****

    Wallpaper can be jpeg or perhaps other file formats, but must have the right file permissions. The easiest way to sort it out is to do a "sudo cp" copy of the image file to either /usr/share/backgrounds or /usr/share/xfce4/backdrops/, essentially what Cesium suggests above. By the way, there are some nice wallpapers preloaded in the /usr/share/backgrounds/nature directory.

    *****

    A USB mouse is configured separately from the trackpad settings, so having different behaviour is expected. Have a look at the mouse properties under the xfce setttings manager.
     
    rjm, Sep 30, 2008
    #10
  11. rjm

    Mako

    Joined:
    Sep 29, 2008
    Messages:
    8
    Re: How to: get the Linpus XFCE desktop to stay after reboot

    Another question: How I can personalize the "Xcfe Menu" button?

    I saw that in /home/user/.config/xfce4/panel/ there is a file .rc for each element in the panel, so there is also a file for the Menu Button: it's called xfce4-menu-ID#.rc ( I think ID# will change at every panel modify)
    I tried to modify this file chaging the lines, but at each reboot this file return at the default value.

    This is the default file:
    Code:
    use_default_menu=true
    menu_file=
    icon_file=/usr/share/pixmaps/xfce4_xicon1.png
    show_menu_icons=true
    button_title=Xfce Menu
    show_button_title=true
     
    Mako, Sep 30, 2008
    #11
  12. rjm

    rjm

    Joined:
    Jul 24, 2008
    Messages:
    345
    Re: How to: get the Linpus XFCE desktop to stay after reboot

    I'm not sure what you want to achieve, but I was just working on a similar problem you might find useful.

    From the main menu, select settings - menu editor

    This will allow you to edit parts of the menu, like the speed links at the top, but the main part is generated automatically from the .desktop files in /usr/share/applications

    Try the following

    Code:
    sudo mv /usr/share/applications/edesktop ~/Documents/edesktop
    That will immediately get rid of the silly "web storage" "google maps" and "wikipedia" item in the xfce menu. It looks pretty clean and businesslike after that.
     
    rjm, Sep 30, 2008
    #12
  13. rjm

    bobynux

    Joined:
    Sep 20, 2008
    Messages:
    7
    Re: How to: get the Linpus XFCE desktop to stay after reboot

    Thanks, everything works like a charm :)
     
    bobynux, Sep 30, 2008
    #13
  14. rjm

    SteveSol

    Joined:
    Aug 27, 2008
    Messages:
    35
    Re: How to: get the Linpus XFCE desktop to stay after reboot

    I followed these instructions but hit a problem just after the first reboot. I get a black desktop and the panel along the bottom, but alt + f2 does nothing and won't bring up the terminal. Help!
     
    SteveSol, Sep 30, 2008
    #14
  15. rjm

    SteveSol

    Joined:
    Aug 27, 2008
    Messages:
    35
    Re: How to: get the Linpus XFCE desktop to stay after reboot

    Er, did a system restore and tried again, it worked, so must have done a typo.. oops. I have a question though. Will live update screw things up or is this update-proof? p.s great guide by the way, thanks!
     
    SteveSol, Sep 30, 2008
    #15
  16. rjm

    soderkvist

    Joined:
    Aug 19, 2008
    Messages:
    9
    Location:
    Sweden
    Re: How to: get the Linpus XFCE desktop to stay after reboot

    I had the same problem. Reinstalled and did it again. Now I have XFCE desktop background instead of just black. alt+F2 still doesn't work but I enabled desktop menu before starting so I can bring up the terminal but the command xfce-setting-show doesn't work! It says "no such file or directory". What is wrong?

    EDIT: I got it working now. Thanks for updating the guide. Obviously I wasn't following the first two times i tried. Now everything looks great, thanks again!
     
    soderkvist, Sep 30, 2008
    #16
  17. rjm

    jccguays

    Joined:
    Jul 28, 2008
    Messages:
    36
    Location:
    Spain
    Re: How to: get the Linpus XFCE desktop to stay after reboot

    Hi, this a screenshot of my desktop.

    About the USB mouse, i have look in the mouse preferences and I don't see anything, so it's just a problem of use. Never mind, I have created launcher inside my new desktop with the things I normally use o want to use.

    Best regards[attachment=0:2mdjo2zj]Pantallazo.jpg[/attachment:2mdjo2zj]
     
    jccguays, Sep 30, 2008
    #17
  18. rjm

    rjm

    Joined:
    Jul 24, 2008
    Messages:
    345
    Re: How to: get the Linpus XFCE desktop to stay after reboot

    The black desktop indicates that xfdesktop-xfce hasn't loaded for some reason. A error somewhere in your file edits. I know because I made the same mistake.

    It should be live-update proof. Live update can modify the Acer desktop files (xfdesktopnew, xfdesktop2) all it wants and we dont care since we aren't using them anymore. Only xfce4-session.rc is vulnerable to being rewritten.
     
    rjm, Oct 1, 2008
    #18
  19. rjm

    rjm

    Joined:
    Jul 24, 2008
    Messages:
    345
    Re: How to: get the Linpus XFCE desktop to stay after reboot

    You know you can put a button on the toolbar that duplicates the right-click menu? Just call

    Code:
    xfce4-panel -a
    and drag and drop the xfce menu button to the toolbar. That saves a lot of desktop clutter.
     
    rjm, Oct 1, 2008
    #19
  20. rjm

    SteveSol

    Joined:
    Aug 27, 2008
    Messages:
    35
    Re: How to: get the Linpus XFCE desktop to stay after reboot

    Thanks again, this is exactly what i've been looking for since buying my One. It is so much better to use now the Acer desktop has gone. Good work! :D
     
    SteveSol, Oct 1, 2008
    #20
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Zorofroozo
    Replies:
    3
    Views:
    824
    Zorofroozo
    Feb 2, 2009
  2. Platti

    New Desktop Wanted...

    Platti, Mar 9, 2009, in forum: Acer Aspire One
    Replies:
    20
    Views:
    1,622
    barrie
    Mar 14, 2009
  3. eleme
    Replies:
    13
    Views:
    4,001
    adrianaitken
    Oct 4, 2009
  4. loverboy
    Replies:
    0
    Views:
    734
    loverboy
    Apr 2, 2009
  5. jjj
    Replies:
    4
    Views:
    602
Loading...

Share This Page