WiFi causing system to stutter, any ideas?

Discussion in 'Linux' started by digitalspaghetti, Sep 26, 2008.

  1. digitalspaghetti

    digitalspaghetti

    Joined:
    Sep 26, 2008
    Messages:
    1
    Likes Received:
    0
    Today I received my Acer Aspire One and promptly installed Ubuntu using the instructions. So far it seemed fine, but then my Wifi stopped working. Then I noticed my system freezing every couple of minutes. I was worried it was a HD issue at first, but I have now discovered it seems to be related to the WiFi

    At the moment, I am plugged into my router, but i'm still getting the freezing - looking at the kern log, I get this when it freezes:

    Code:
    Sep 26 22:15:07 tane-aspireone kernel: [ 8638.948440] wifi0: ath_chan_set: Unable to reset channel 1 (2412 MHz) flags 0xc0 '' (HAL status 3246398208)
    Sep 26 22:15:08 tane-aspireone kernel: [ 8640.078889] wifi0: ath_chan_set: Unable to reset channel 6 (2437 MHz) flags 0xc0 '' (HAL status 1964899393)
    Sep 26 22:15:10 tane-aspireone kernel: [ 8641.406220] wifi0: ath_chan_set: Unable to reset channel 7 (2442 MHz) flags 0xc0 '' (HAL status 3295566725)
    Sep 26 22:15:11 tane-aspireone kernel: [ 8642.535971] wifi0: ath_chan_set: Unable to reset channel 2 (2417 MHz) flags 0xc0 '' (HAL status 130528125)
    Sep 26 22:15:12 tane-aspireone kernel: [ 8643.667338] wifi0: ath_chan_set: Unable to reset channel 3 (2422 MHz) flags 0xc0 '' (HAL status 1261378818)
    Sep 26 22:15:13 tane-aspireone kernel: [ 8644.793684] wifi0: ath_chan_set: Unable to reset channel 4 (2427 MHz) flags 0xc0 '' (HAL status 2385343879)
    Sep 26 22:15:14 tane-aspireone kernel: [ 8645.924584] wifi0: ath_chan_set: Unable to reset channel 5 (2432 MHz) flags 0xc0 '' (HAL status 3519155270)
    Sep 26 22:15:15 tane-aspireone kernel: [ 8647.052528] wifi0: ath_chan_set: Unable to reset channel 8 (2447 MHz) flags 0xc0 '' (HAL status 352201100)
    Sep 26 22:15:16 tane-aspireone kernel: [ 8648.062533] wifi0: ath_chan_set: Unable to reset channel 9 (2452 MHz) flags 0xc0 '' (HAL status 1359236125)
    Sep 26 22:15:18 tane-aspireone kernel: [ 8649.190778] wifi0: ath_chan_set: Unable to reset channel 10 (2457 MHz) flags 0xc0 '' (HAL status 2490159524)
    Sep 26 22:15:19 tane-aspireone kernel: [ 8650.320849] wifi0: ath_chan_set: Unable to reset channel 6 (2437 MHz) flags 0xc0 '' (HAL status 4072719856)
    
    Now, since resetting, my WiFi has disappeared :| I've recompiled the driver and re-installed with no luck, and I can't see any errors in my logs now relating to wifi0, not even ones where it fails to initialize.

    Anyone any idea's what's going on?

    UPDATE!!

    Seems it's the old IT solution of turn it off and turn it on again! According to this thread viewtopic.php?f=28&t=3775 a reboot just doesn't fix it. Can confirm this (annoying) fix works for me.
     
    digitalspaghetti, Sep 26, 2008
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.