Ubuntu 9.04 and noisy fan

Discussion in 'Linux' started by calvin, May 7, 2009.

  1. calvin

    calvin

    Joined:
    Aug 30, 2008
    Messages:
    5
    Likes Received:
    0
    I installed Ubuntu 9.04 on my AA1 (a0a 150) via a Wubi installation. The fan will not stop running even though the laptop is cool to the touch.

    I tried this fix:

    Some Acer Aspire One netbooks out there suffer from a noisy fan. Mine too and it was really starting to drive me crazy. I really wouldn’t want to be caught using it in a quiet place like a library for example. Luckily there’s a couple of scripts you can use to control the fan. The aspireone.net Wiki has all the details, but here’s a quick rundown of what you need to do to get rid of the noise:

    download the acerfand daemon script
    download the acer_ec.pl script (direct download)
    Copy both files to /usr/local/bin
    make acerfand executable using chmod 755 /usr/local/bin/acerfand
    open /etc/rc.local as root (or use sudo) and add /usr/local/bin/acerfand at the end of the file

    This did not change a thing. Does the Wubi installation prevent Ubuntu from controlling the fan?
     
    calvin, May 7, 2009
    #1
    1. Advertisements

  2. calvin

    mindhack

    Joined:
    Apr 25, 2009
    Messages:
    35
    Likes Received:
    0
    Location:
    Sequim, Wa
    For one, wubi is not the way to go, its a bad idea IMO on so many different levels.
    For two, slowing a system fan down or turning it off is a bad idea, it really is not that loud (at least mine is not) and it is there for a purpose.

    The wubi install might very well affect this, but I am unsure. I would do a normal install and see if its still too loud for you likings. If it is, let us all know.
     
    mindhack, May 7, 2009
    #2
    1. Advertisements

  3. calvin

    triacontahedron

    Joined:
    Aug 17, 2008
    Messages:
    8
    Likes Received:
    0
    The other day I screwed up like a n00b. For a few days I was bothered by some hissing noise from my aspire one, it sounded like a fan was working full speed. I was quite bothered by this and began monitoring cpu usage and temperature, both were quite low. So after some fiddling around it turns out my internal mic boost was on max level and, considering shitty quality, the sound system was outputting white noise on internal speakers. Not sure if your problem is similar but maybe it is worth checking.
     
    triacontahedron, May 7, 2009
    #3
  4. calvin

    calvin

    Joined:
    Aug 30, 2008
    Messages:
    5
    Likes Received:
    0
    My problem is the fan. I put all volume levels to minimum and applied mute. Same level of noise and air is coming out of the exhaust vent.
     
    calvin, May 7, 2009
    #4
  5. calvin

    jango

    Joined:
    Aug 2, 2008
    Messages:
    307
    Likes Received:
    0
    What about this...

     
    jango, May 7, 2009
    #5
  6. calvin

    calvin

    Joined:
    Aug 30, 2008
    Messages:
    5
    Likes Received:
    0
    I just tried this. Error 2 about not finding a subdirectory. Ubuntu is not worth the effort.
     
    calvin, May 8, 2009
    #6
  7. calvin

    mkfort

    Joined:
    Jun 13, 2009
    Messages:
    9
    Likes Received:
    0
    Sorry to bump an old post but this completely misses the point. There is a bug where the fan runs at max all the time, much more than it needs to stay within the proper operating temperatures. This disadvantage of this is not the noise ( I agree it's not horribly noisy) but that it drains the battery much faster. Given that one of the main advantages of the AA1 is long battery life, this is a serious issue.

    Mine has this problem but it's off for repairs right now. When it gets back I'll try the workaround. Let us hope that in the future they fix it in the kernel. Or I could fix it I suppose but I'm not a kernel expert.
     
    mkfort, Jun 28, 2009
    #7
  8. calvin

    ryanc021

    Joined:
    Nov 20, 2008
    Messages:
    32
    Likes Received:
    0
    Location:
    London, England
    I also suffered this problem, i was missing the linux-headers to compile the acerhdf module. Doing the following command should grab the linux-headers needed to successfully install the module....
    Code:
    sudo apt-get install linux-headers-$(uname -r)
    and a question? do you control the temperature the same way as with the old acerfand script with the /etc/acerfand.conf file or is it done differently now?

    i'd really like to know, thanks in advance.
     
    ryanc021, Jun 28, 2009
    #8
  9. calvin

    DutchDK

    Joined:
    Jun 2, 2009
    Messages:
    338
    Likes Received:
    0
    Location:
    Copenhagen
    Allways a good idea to read the included readme file :
    CONFIGURATION / PARAMETERS
    acerhdf has following parameters:
    o interval=10 - The interval in seconds, in which the temperature should be
    checked in kernel mode. (default=10)
    o fanon=67 - The temperature in Celsius above the fan should be switched on.
    (default=67)
    o fanoff=62 - The temperature in Celsuis below the fan should be switched
    off. (default=62)
    o verbose=0 - Print out verbose messages to dmesg. (default=0)
    o force_bios="" - For testing purposes, see below.

    Those parameters can be set when loading the module. E.g:
    'modprobe acerhdf interval=5 fanon=65 fanoff=60'
    You can add them to '/etc/modprobe.conf', so that they are automatically
    applied, when the module is loaded. The line in modprobe.conf can look like
    this:
    'options acerhdf interval=5 fanon=65 fanoff=60'
     
    DutchDK, Jun 28, 2009
    #9
  10. calvin

    libssd

    Joined:
    Jan 17, 2009
    Messages:
    244
    Likes Received:
    0
    Location:
    Atlanta, GA
    About 10 days ago I installed Ubuntu 9.04 in a partition on an AA1 150; there is no discernible fan noise (beyond a very subdued hum), although the fan whooshes briefly (1-2 sec) when first powered on, until it gets to the grub boot menu. Acer BIOS v1.05.

    Although it doesn't automatically suspend when I close the lid (despite a config setting to do so), manual suspend works correctly. If I just close the lid, the fan keeps running, there are intermittent disk accesses, and it never cools down; with a proper suspend, the fan shuts off within seconds.
     
    libssd, Jun 29, 2009
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.