strange wifi problem

Discussion in 'Networking' started by erydj, Apr 9, 2009.

  1. erydj

    erydj

    Joined:
    Jan 31, 2009
    Messages:
    1
    Likes Received:
    0
    Folks, I have a very strange wifi problem: my linpus AAO cannot connect to the wireless router at home. What makes it strange is that the wifi works fine in my office or even in cafe.

    I know it should be my router at home (netgear), but I do not know what exactly it is. All other computers running MS-Windows work fine with the router. To make it even more complicated, the AAO can actually detect the wireless signal. It just wont connect.

    I have tried all possible combinations: changing the essid, broadcast on/off, try with no security, with WEP, with WPA, change the channel, I cant remember what else, but I am running out of ideas here.

    Anybody can help me please?
     
    erydj, Apr 9, 2009
    #1
    1. Advertisements

  2. erydj

    philyoung

    Joined:
    Apr 1, 2009
    Messages:
    3
    Likes Received:
    0
    I've recently aquired a Linux AAO and have "issues" connecting to my netgear router.

    I'm not broadcasting my SSID.
    I've got MAC address filtering turned on (and the AAO is in the access list).
    I'm using WPA-PSK security.

    When I turn on the AAO, it finds my wireless network and attempts to connect to it.
    After a short while it prompts me for the password to connect - this password is already set in the network settings.
    If I cancel the above login screen it tells me the network has been disconnected and then attempts to connect again.
    This second attempt always works and doesn't require me to enter my password.

    A bit of a strange one, but i'm living with it.

    I wonder if yours is doing the same (or something similar).

    I'm guessing the netgear is taking too long to authenticate (or something else) so the AAO thinks it has failed and prompts for the password.
    If this is the case, there's probably a setting somewhere that I can increase to give it more time?

    If I had more Linux knowledge, I'd have a go at debugging what's going on with the connection - can anyone offer advice?

    Cheers

    Phil
     
    philyoung, Apr 9, 2009
    #2
    1. Advertisements

  3. erydj

    arunr450

    Joined:
    Apr 10, 2009
    Messages:
    3
    Likes Received:
    0
    Goto the connection manager, create a wlan connection enter SSID and WEP key if available...then select next...and finish....Now goto the connection manager and edit the setting...enter the TCP/IP values manually..then click finish ...hope it works
     
    arunr450, Apr 10, 2009
    #3
  4. erydj

    vxd240

    Joined:
    Jun 28, 2009
    Messages:
    1
    Likes Received:
    0
    same problem. I use manual IP addresses, not DHCP. I've tried deleting connection, and re-adding, but no go. I tried adding by typing in manually and by selecting from the scan list, no go. it's one of those little annoyances that's very...annoying. Would appreciate if someone has an answer.
     
    vxd240, Jun 28, 2009
    #4
  5. erydj

    philyoung

    Joined:
    Apr 1, 2009
    Messages:
    3
    Likes Received:
    0
    Well I did an auto update thingy yesterday and it appears to have fixed my issue.
    The network manager was one of the updated components.
    It now connects to my netgear router first time! Woohoo!

    Phil
     
    philyoung, Aug 12, 2009
    #5
  6. erydj

    mprhat

    Joined:
    Aug 31, 2009
    Messages:
    2
    Likes Received:
    0
    Dear all,

    I seem to be having a similar problem.
    I can connect to my LAN with cable, but no connection via WLAN. I have typed in the WEP correctly yet nothing really works.
    Network Manager detects all networks yet does not connect to them via WLAN. Yes.. NW icon does work.

    I briefly was able to connect to an open WLAN but lost that as well.

    Please does anyone have any ideas?

    I am at wits end and have now heard of too many problems with ACER One and Linpus regarding Network Manager... this defeats the purpose of a netbook!
    Acer needs to get its act together.

    -mprhat
     
    mprhat, Aug 31, 2009
    #6
  7. erydj

    Tynged

    Joined:
    Sep 3, 2009
    Messages:
    3
    Likes Received:
    0
    I was having the exact same problem as erydj. Unprotected networks like the ones on my university's campus worked perfectly, however the WLAN at home would constantly disconnect me.

    But I found the problem that was causing this, at least for me. Apparently when I set up my preferred network for my home WLAN, it defaulted to IEEE 802.1x authentication.

    Here's how I fixed it:
    1. Open up 'Network Connections'[/*:m:2761owpt]
    2. Right-click on 'Wireless Network Connection' and select 'Properties'[/*:m:2761owpt]
    3. Go to the 'Wireless Networks' tab[/*:m:2761owpt]
    4. Left-click on the correct preferred network[/*:m:2761owpt]
    5. Click 'Properties'[/*:m:2761owpt]
    6. Go to the 'Authentication' tab[/*:m:2761owpt]
    7. Clear 'Enable IEEE 802.1x authentication for this network'[/*:m:2761owpt]
    8. Click 'OK' to apply the preferred network properties[/*:m:2761owpt]
    9. Click 'OK' again to apply the 'Wireless Network Connection' properties[/*:m:2761owpt]

    After doing this I had instant connectivity and haven't lost it again yet. So if you know you don't need IEEE 802.1x authentication or have no idea what it is, you might try switching this off and see if it works for you.
     
    Tynged, Sep 6, 2009
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.