Network Manager issues related to Power Issues?

Discussion in 'Networking' started by agelade, Apr 6, 2009.

  1. agelade


    Feb 16, 2009
    Likes Received:
    Edit: I'm sure this has happened before, and I apologize. I've made an updated post in the Linux newbs forum because developments have come to light that make me think it's not a wireless issue, but more widespread. Sorry for the apparent double post. In case someone else has insight or a similar problem, I'll leave this here - I imagine I'm not the first person to notice wireless issues first and decide it's a wireless problem.

    The backstory:

    I have an 8 gig Linux One. I had to install a network manager that could handle my school's WPA nonsense, so I did, following instructions found here: viewtopic.php?f=34&t=1028&. It worked admirably well, auto-detecting it both at school and here at home. It didn't save my passwords, but I was too lazy to implement the fix for that. Otherwise, completely awesome and I went about my business. The only issue with it is that when my One suspends either from being closed or from sitting idle, the network manager icon disappears from the tray and the wireless connection pffs into thin air. The fix? Don't let it go to sleep, and restart it to get internet back when it does.

    Ok, so the problem:

    Uh... the fix doesn't work anymore. My computer went to sleep, I restarted it to get back online. It took forEVER to shutdown, so I ended up doing a hard shutdown by holding down the power button. Then it took forever to restart, and when it finally came back up (after another hard shutdown), the network manager icon was present, but the dialog box that usually pops up for my password never appeared. I right clicked on the connection manager icon to manually try to connect to the wireless router, but instead of having my wireless connection and several other neighborhood wireless networks as options, there's only a greyed out "No network devices available" and a selectable "VPN Connections" option. No wireless networks at all! Because I have that WPA business for school, I don't have a traditional Network manager thing, so I can't even really troubleshoot it.

    Not sure if this is related, but my battery meter now shows only the "Plugged in" icon, even when my One isn't plugged in. Maybe they're related, since they're both in the tray?

    The most recent thing I did was on Friday - uninstalling and reinstalling Cairo dock for unrelated reasons. Other than that, I've installed VLC and GIMP and have the desktop switcher so I can use the regular XFCE desktop. It's worked just as expected (read: not perfectly, but not any weird bugs) after everything I've modified, except I tried to update java and it didn't work - but that just failed, it didn't give me any errors or anything, AND that was saturday. It worked fine after that up til this issue.

    Anyone have any insight? I'm pretty bummed.

    ps, I did search for related stuff, but I didn't see anything that helped me.
    agelade, Apr 6, 2009
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.