Need an opinion, screen messed up or it's connector? MSI GE72 2QF APACHE PRO lap

Discussion in 'Laptop Hardware' started by tomoor90, Apr 16, 2018.

  1. tomoor90

    tomoor90

    Joined:
    Apr 16, 2018
    Messages:
    3
    Likes Received:
    0
    Hi,
    I have this GE72 2QF APACHE PRO laptop for about 2 years. (using it for ~1.5).
    The screen had burned green pixel on it from day one :( But never mind that...

    I always had it connected to a separate monitor and used that other monitor as the main display, and turning ON and OFF the laptop's when I need an extra screen, in Extend mode.
    Yesterday while i was playing some YouTube videos on the laptop display and playing Hearthstone on the main display (the external one) I noticed the colors on the laptop's went pink.
    A text from the YouTube video got burned on the screen (so it was visible if I put a white background there).
    And turning it on and off didn't fixed it.


    Opening/Closing the lid slightly (or more than that) doesn't seem to cause any effect on the colors, they are just pink when the display is ON.
    I added links to 2 YouTube videos I recorded showing what I'm talking about.
    Links:
    Video 1 Video 2


    I wonder if it's the screen's fault or it's internal connector to the laptop's motherboard/GPU (so replacing the screen won't help) ?

    Hope you have some knowledge about this, Thank you.
     
    tomoor90, Apr 16, 2018
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.