M-Audio Transit USB sound card (Linpus Linux)

Discussion in 'Linux' started by Phil_Urich, Oct 5, 2008.

  1. Phil_Urich

    Phil_Urich

    Joined:
    Aug 29, 2008
    Messages:
    44
    Likes Received:
    0
    I've been trying to get this thing working for a bit now, but no luck. I've had it running fine on my (K)Ubuntu machines, but I've been putting off replacing the default install on the AA1 and thus I've been trying to get it installed in Linpus. There are some pretty good guides out there, such as http://www.diyaudio.com/wiki/index.php?page=LINUX+Audio+MAudioTransit, but they mostly tend to be either old or Ubuntu-centric, and all of them have in common that they don't work for me, heh.

    I've tried the madfu drivers normally, and with the tweak for modern udev, and no go either way. It shows up quite normally in lsusb, just like with any of my Kubuntu machines, but it doesn't show up in /proc/asound/cards or as an option in Audacity (which is really what I need it for, since I'm wanting to use the AA1 as a silent ultraportable recording laptop).
     
    Phil_Urich, Oct 5, 2008
    #1
    1. Advertisements

  2. Phil_Urich

    Phil_Urich

    Joined:
    Aug 29, 2008
    Messages:
    44
    Likes Received:
    0
    ummm okay, failing that though, does anyone know what precise version of udev the AA1's Linpus uses, or how I could figure that out? That would certainly help me in tracking down why precisely it isn't working.
     
    Phil_Urich, Oct 9, 2008
    #2
    1. Advertisements

  3. Phil_Urich

    cpchan

    Joined:
    Sep 22, 2008
    Messages:
    201
    Likes Received:
    0
    I love M-Audio equipment.

    I believe your problem is that Linpus does not include the driver. Although I can't find the device in ALSA's sound card matrix, I suspect it uses usb-audio like all other M-Audio (and other) usb devices. Try downloading the alsa-drivers and compile it with:

    Code:
    ./configure --enable-cards=usb-audio,intel-hda --with-sequencer=yes&&make&&make install&&depmod -a
    and try again. You might need to reboot to run "depmod -a" if you get unresolved symbols.
     
    cpchan, Oct 9, 2008
    #3
  4. Phil_Urich

    Phil_Urich

    Joined:
    Aug 29, 2008
    Messages:
    44
    Likes Received:
    0
    Hmm, thanks for the response, I'll definitely try that. I know it needs firmware to be uploaded to it upon hotplug, and i was thinking that was the stage at which I was having problems, but yeah, maybe AA1 Linpus' alsa doesn't have the usb-audio drivers, good idea!
     
    Phil_Urich, Oct 9, 2008
    #4
  5. Phil_Urich

    cpchan

    Joined:
    Sep 22, 2008
    Messages:
    201
    Likes Received:
    0
    I know it doesn't. I checked the sound card modules installed and the only one included is hda-intel for the on board sound.
     
    cpchan, Oct 9, 2008
    #5
  6. Phil_Urich

    blackhawk

    Joined:
    Aug 19, 2008
    Messages:
    122
    Likes Received:
    0
    Not sure since I have no usb audio device but you can try this:
    Code:
    $ sudo ./madfuload -l -3 -f ma006100.bin
    $ sudo insmod snd-rawmidi.ko
    $ sudo insmod snd-usb-lib.ko
    $ sudo insmod snd-usb-audio.ko
    
    All binary and kernel module attached.
    [attachment=0:14gtxedm]transit-usb.zip[/attachment:14gtxedm]
     
    blackhawk, Oct 9, 2008
    #6
  7. Phil_Urich

    cpchan

    Joined:
    Sep 22, 2008
    Messages:
    201
    Likes Received:
    0
    Why are you using 3 commands to insert the modules? You can do it in one go by running:

    Code:
    sudo modprobe usb-audio
    as long as your modules.dep is up to date (by running "depmod -a"). Anyway the better option is to use alsaconf.
     
    cpchan, Oct 9, 2008
    #7
  8. Phil_Urich

    blackhawk

    Joined:
    Aug 19, 2008
    Messages:
    122
    Likes Received:
    0
    No udev or modprobe, just for test purpose. If it's works, I am sure the original poster will fix my way :)
     
    blackhawk, Oct 9, 2008
    #8
  9. Phil_Urich

    Phil_Urich

    Joined:
    Aug 29, 2008
    Messages:
    44
    Likes Received:
    0
    No luck with the binaries; well, some luck (and thanks!) but it errors on the last module.
    Code:
    [[email protected] transit-usb]$ sudo insmod snd-usb-audio.ko
    insmod: error inserting 'snd-usb-audio.ko': -1 Unknown symbol in module
    Compiling ALSA myself doesn't get much happier, alas:
    Code:
    checking for directory with kernel source... ./configure: line 4685: cd: /lib/modules/2.6.23.9lw/source: No such file or directory
    /lib/modules/2.6.23.9lw/source
    checking for directory with kernel build... /lib/modules/2.6.23.9lw/build
    checking for kernel linux/version.h... no
    The file /include/linux/version.h does not exist.
    Please install the package with full kernel sources for your distribution
    or use --with-kernel=dir option to specify another directory with kernel
    sources (default is /lib/modules/2.6.23.9lw/source).
    
    I feel so helpless, in Debian(-based) I'd have those kernel sources in a jiffy, but I can't seem to find the package with yum or Pirut. It's like I've suddenly regressed to being a Linux newbie, heh.

    Definitely getting somewhere though, and I think I'm understanding ALSA better :)
     
    Phil_Urich, Oct 18, 2008
    #9
  10. Phil_Urich

    blackhawk

    Joined:
    Aug 19, 2008
    Messages:
    122
    Likes Received:
    0
    I will upload the latest alsa module (with usb sound support) for kernel 2.6.23.9lw, maybe on Monday.

    For your module building problems, seems like you have no kernel source in /usr/src/linux-2.6.23.9lw .
     
    blackhawk, Oct 18, 2008
    #10
  11. Phil_Urich

    Phil_Urich

    Joined:
    Aug 29, 2008
    Messages:
    44
    Likes Received:
    0
    That would be amazing, you are a downright saint.

    I've actually been trying to install the kernel source, but I cannot seem to find a suitable package for it; by most accounts kernel-devel seems to be all I need, but that installs /usr/src/kernels/2.6.23.1-42.fc8-i686, and I cannot find any sources for 2.6.23.9lw anywhere. Maybe the 2.6.23.9 vanilla source would do, but I don't know if I even have enough room to extract the archive, hah! (I lost my mp3 player yesterday, which had my 16GB SDHC card in it at the time....which means that when I get the Transit working I won't have any place to record things to yet again until I buy another!)
     
    Phil_Urich, Oct 19, 2008
    #11
  12. Phil_Urich

    blackhawk

    Joined:
    Aug 19, 2008
    Messages:
    122
    Likes Received:
    0
    Kernel 2.6.23.9lw with all USB driver enabled: http://rapidshare.com/files/156029097/l ... r.bz2.html, including the latest ethernet, wireless, webcam, and sound driver.

    Tested on my own Aspire One but I am not responsible for any damage to your machine caused by this kernel update!

    Code:
    $ sudo mv /boot/bzImage /boot/bzImage.orig
    $ sudo mv /lib/modules/2.6.23.9lw/lib/modules/2.6.23.9lw.orig
    $ cd /
    $ tar xvjf /home/user/Downloads/linux-2.6.23.9lw-aspireone.tar.bz2
    
    Reboot.

    Have no XD and memory stick driver but you can take it from the original kernel:
    Code:
    $ sudo cp -a /lib/modules/2.6.23.9lw.orig/kernel/drivers/jmb38x /lib/modules/2.6.23.9lw/kernel/drivers/
    $ sudo depmod -a
    
    After above kernel update, for M-Audio Transit USB:
    Code:
    $ sudo ./madfuload -l -3 -f ma006100.bin
    $ sudo modprobe snd-usb-audio
    
    To see loaded module and kernel message:
    Code:
    $ lsmod
    $ dmesg
    
     
    blackhawk, Oct 21, 2008
    #12
  13. Phil_Urich

    Maegashira

    Joined:
    Oct 21, 2008
    Messages:
    1
    Likes Received:
    0
    is there any way to tell them to support usb audio in the future?
    i was planning to buy me an aspire one in near future to use it with my hifi amplifier and creative-xfi xmod for listening to web radio and mp3s in the living room. its not a big problem to build the kernel modules anyway but it simply turns me off. kernel sources can be installed via the repository, can they?
     
    Maegashira, Oct 21, 2008
    #13
  14. Phil_Urich

    Japser

    Joined:
    Aug 28, 2008
    Messages:
    267
    Likes Received:
    0
    Very good work Blackhawk. Very usefull, I think.
    One question: would you publish the config-file ?

    --Japser.
     
    Japser, Oct 21, 2008
    #14
  15. Phil_Urich

    Phil_Urich

    Joined:
    Aug 29, 2008
    Messages:
    44
    Likes Received:
    0
    Thank you tremendously, blackhawk!

    It seems all to be working on the base level:

    Code:
    [[email protected] ~]$ cat /proc/asound/cards
     0 [Intel          ]: HDA-Intel - HDA Intel
                          HDA Intel at 0x38540000 irq 16
     1 [USB            ]: USB-Audio - Transit USB
                          M-Audio Transit USB at usb-0000:00:1d.0-1, full speed
    
    lsmod:
    Code:
    snd_timer              11012  2 snd_seq,snd_pcm
    snd_page_alloc          4360  2 snd_hda_intel,snd_pcm
    snd_mixer_oss           9856  1 snd_pcm_oss
    snd                    27300  12 snd_usb_audio,snd_usb_lib,snd_rawmidi,snd_hwdep,snd_hda_intel,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_pcm,snd_timer,snd_mixer_oss
    soundcore               2976  1 snd
    
    Although...one tiny problem remains. Ummm, I can't seem to be able to use it, haha. Audacity doesn't give any of the Transit's inputs or outputs as options, and Amarok fails to give me any options either (at which point did they make the OSS device a drop-down selection instead of an entry field? otherwise I could probably just go /dev/dsp1 and it'd be fixed there, although Amarok isn't exactly the focus here).

    Edit: halfway through writing this, I found a "solution"...but the problem itself seems unsolved, so I'll leave the following intact so people can see what I've tried and what I figure the problem is.

    I tried making a .asoundrc file:

    Code:
    cm.!default {
        type hw
        card 1
    }
    ctl.!default {
        type hw
        card 1
    }
    
    ...but perplexingly, upon reboot Audacity was missing an option; before the options were OSS on /dev/dsp, ALSA on the intel sound card, and ALSA on default....now the ALSA default option is missing!

    I'm thinking perhaps it's a permissions problem, especially since alsamixer lets me toy with the Transit's in and out levels, but only if I run it as root or sudo, which seems wrong.

    Code:
    alsamixer: function snd_ctl_open failed for default: Permission denied
    
    And furthermore, when I yank out the Transit it gives the same error except "No such file or directory" instead of "Permission denied". The Transit seems to be /dev/dsp1, and while /dev/dsp shows up in permissions as being "user" for user and "root" for group, /dev/dsp1 is root for both attributes, which it won't let me change (and I assume on the block device would not be where I'd change it anyways). I tried just running Audacity as root, but instead it gives no options for audio devices, period.

    ---------
    Edit: when I said that I ran Audacity as root, I had run it as "sudo audacity".... instead going "sudo su" and then from there running Audacity, everything works fine! It shows all the audio device options including /dev/dsp1 and ALSA Transit USB. It's probably something simple that I don't know how to do, but even if there's no easy way to give "user" permissions for /dev/dsp1 it's no worries since I guess I can just run things as root, bad security practices be damned ;)

    Anyways, once again, thank you, blackhawk! You've let me set up and do what I primarily bought this netbook to do in the first place!
     
    Phil_Urich, Oct 24, 2008
    #15
  16. Phil_Urich

    cpchan

    Joined:
    Sep 22, 2008
    Messages:
    201
    Likes Received:
    0
     
    cpchan, Oct 24, 2008
    #16
  17. Phil_Urich

    clanduncan

    Joined:
    Oct 29, 2008
    Messages:
    17
    Likes Received:
    0
    I've been following this thread, as I have exactly the same problem, though I'm using a Creative USB device. Plain vanilla mp3+ model in stereo. Blackhawk's instructions were easy to follow and worked. Then Phil's extra tips came in handy. Like Phil, Audacxity doesn't detect the USB device when run from the desktop, but when run from a terminal, it picks up the device perfectly, both line-in and line-out.

    Sorry in advance for this following suggestion (being an ignorant Linux newbie myself);- but like in WinXP where you can set up an icon on a desktop to run a script behind the scenes, could not the same be done here so that Phil's tip on running Audacity from a terminal happens in the background when clicking on a desktop or menu icon? That way it would pickup the USB audio devices properly, as we all want it to do. Seems so near and yet so far from just being a perfect solution.
     
    clanduncan, Nov 5, 2008
    #17
  18. Phil_Urich

    ryanc021

    Joined:
    Nov 20, 2008
    Messages:
    32
    Likes Received:
    0
    Location:
    London, England
    I followed the instructions and everything installed just fine, so a big thanks for the hard work Blackhawk :D . I've been able to use my USB device via XMMS player which is selectable under the Asla output plugin, so thats another option for thoses who didn't already know.

    My problem is unrelated to the USB but the Madwifi drivers. I had problems with the 'WLAN kill switch' not working, once i'd found the kill switch codes and added them to the rc.local file, I subsequently had the really annoying 'Disconnected...' notification pop up every few minutes once I used the kill swtich.

    So my question is the a way to avoid installing the drivers at all? or once installed remove them and replace the orignal wifi drivers. As I intend to redo this install once i've restored the backup image I made.
     
    ryanc021, Nov 24, 2008
    #18
  19. Phil_Urich

    madeyemoody

    Joined:
    Aug 21, 2008
    Messages:
    18
    Likes Received:
    0
    Blackhawk, many thanks for posting the instructions! :p

    I want to use small usb speakers from Trust with my One. At the moment I'm at the stage where Amarok works if I start it with 'sudo amarok' and enter 'hw:1,0' as the stereo audio device in amaroks audio engine options (using alsa). Alsamixer also only shows my usb device if I start it with sudo.... Question is how do I access my usb speakers as a normal user? It would be nice if someone can some explicit instructions what to change! My other question is whether it is possible to automatically make the usb device the default once it is pluged in?

    It seems that after Blackhawks update the network does not survive the sleep state. It simply is unable to connect (small network icon spinning...). This applies to wifi and wired network. Is there a cure to this glitch?

    thanks for any help!
     
    madeyemoody, Nov 27, 2008
    #19
  20. Phil_Urich

    madeyemoody

    Joined:
    Aug 21, 2008
    Messages:
    18
    Likes Received:
    0
    did some more tests and found out the following:

    1. case - usb speakers unplugged during boot
    need sudo etc to get sound

    2. case - usb speakers plugged in during boot:
    the speaker device becomes the default sound device and all sound progs use it!!!

    not the ideal case but I think I can live with it. Only thing that is bothering me is the dying of my LAN after sleep...
     
    madeyemoody, Nov 27, 2008
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.