Linpus- how to get regular desktop to stay

Discussion in 'Linux' started by bach_tenor, Sep 11, 2008.

  1. bach_tenor

    bach_tenor

    Joined:
    Aug 18, 2008
    Messages:
    6
    Likes Received:
    0
    I went through a guide to enable the right click menu, and a couple days ago I disabled the simplified desktop so I could use a regular desktop. I rebooted a couple times and the regular desktop showed up along with a few icons (home, filesystem, trash).

    I added my own shortcuts onto the desktop and rebooted again to make sure they stayed, and the desktop came up and the shortcuts appeared so that was fine.
    Now I reboot and I get a blue background that says "XFCE" in the middle, plus there are no icons at all on the desktop.

    The only thing that changed was that I installed Pidgin IM, and that included uninstalling the lilpurple library and replacing it with a newer one.
    Would this cause the problem I am having or is it unrelated?

    I am still able to go into the terminal and type "xfdesktop-xfce" and my normal desktop and icons show up just like I had them before. Why can't I get this to come up automatically.

    I edited my /etc/xdg/xfce4-session/xfce4-session.rc like so:
    Code:
    #Client0_Command=xfdesktopnew
    Client0_Command=xfdesktop-xfce
    Client0_PerScreen=False
    Client1_Command=xfwm4
    Client1_PerScreen=False
    Client2_Command=xfce4-panel
    Client2_PerScreen=False
    #Client3_Command=/usr/share/search-bar/start-search_bar.sh
    Client3_Command=xfce-mcs-manager.new
    Client3_PerScreen=False
    Client4_Command=xfcepost
    Client4_PerScreen=False
    I've checked over that code a couple times and can find nothing wrong, and it was working a few time before so I am baffled. Anyone have an idea?
    It's not that big of a deal to have to open the terminal and just type xfdesktop-xfce, but I'd like it if it was just automatic.
     
    bach_tenor, Sep 11, 2008
    #1
    1. Advertisements

  2. bach_tenor

    IMSancho

    Joined:
    Aug 14, 2008
    Messages:
    95
    Likes Received:
    0
    Location:
    Australia
    Try moving your /home/user/.config/xfce4 directory to another location temporarily and restart, I have had some corruption in that directory cause the desktop to not come up before.
     
    IMSancho, Sep 12, 2008
    #2
    1. Advertisements

  3. bach_tenor

    bach_tenor

    Joined:
    Aug 18, 2008
    Messages:
    6
    Likes Received:
    0
    Thanks, Sancho, that worked and the desktop has showed up correctly since then every time I boot.

    I actually restored the OS using the CD and gave it another shot, I enabled the advanced menu and the desktop and it worked for a while. Then I tried installing Pidgin again and the problem cropped up again.

    I'm not exactly sure what that breaks, but getting rid of that folder seems to have fixed it.

    Thanks again.
     
    bach_tenor, Sep 13, 2008
    #3
  4. bach_tenor

    rjm

    Joined:
    Jul 24, 2008
    Messages:
    345
    Likes Received:
    0
    I had the same difficulties after making the same edits. I never actually got in a position to have my own desktop icons. I'll certainly try deleting or moving my .config/xfce4/desktop data, but I'd really like an explanation of what's going on:

    1. What are xfce4-panel and xfce-mcs-manager.new, what do they do, and where are the related config files?

    2. Is the Acer desktop something that can be uninstalled, like the search bar can be uninstalled? This would seem to be a cleaner way of getting rid of it.

    TIA
     
    rjm, Sep 13, 2008
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.