KPN (NL) ZTE MF628 usb 3g modem working on Linpus

Discussion in 'Networking' started by Japser, Aug 28, 2008.

  1. Japser

    Japser

    Joined:
    Aug 28, 2008
    Messages:
    267
    Likes Received:
    0
    It took a long time, but after all it turned out to be easy.
    I did this for my neighbour, so I don't have the machine any more, I go from memory and some notes.
    Just stick this thing in an usb-port.
    The lights will come up, and the filemanager pops up, announcing a 'cdrom'.
    Tell the 'cdrom' to eject, lights on stick go out and on again.
    Note that -nothing- has to be done by the user so far.
    ( In the background this has happened: the modules 'usbserial' and 'onda' have loaded, and the devices /dev/ttyUSB0 etc. have been created, automatically and out-of-the-box, it only takes these -two- stages in the beginning. )

    What has to happen now to make an internet connection is 'sudo wvdial'.
    But before that we must edit the file /etc/wvdial.conf .
    Alt-f2 gives a 'run program' dialog, just tick the 'run in terminal' box and you get a terminal.
    Code:
    sudo mousepad /etc/wvdial.conf
    Sorry, but I lost some details here, but go here: http://www.xs4all.nl/~ernstagn/GPRS-HOWTO/.
    It needs a pin code, like: at+cpin=0000
    http://www.taniwha.org.uk/gprs.html tells us this:
    That is user = KPN pass = gprs but I doubt whether this is important, the thing just dials by itself !
    For me this made a connection, and sometimes it even had the 'dns' right.
    To avoid dns-problems do this: sudo mouspad /etc/resolv.conf

    Code:
    nameserver 62.133.126.28 
    nameserver 62.133.126.29
    is what it needs.

    The basic message is: it needs very little, the proper modules ( usbserial and onda ) loaded completely automatic.
    ( check with
    Code:
    lsmod | grep usb
    ) and use
    Code:
    dmesg
    repeatedly to see what is going on.
    Then all it needs is to be told to dial.

    --Japser.
     
    Japser, Aug 28, 2008
    #1
    1. Advertisements

  2. Japser

    Phill

    Joined:
    Aug 24, 2008
    Messages:
    2
    Likes Received:
    0
    Hi,

    I've tried to get this working but no matter what I do (tried following other tutorials around the net which suggest editing some rules but I'm still a linux newb!) I've also tried restarting, shutting down etc. and also I don't even see a ttyusb in /dev/ :s. All I get when I try and start the modem with wvdial is the following:

    --> WvDial: Internet dialer version 1.60
    --> Cannot open /dev/ttyUSB0: No such file or directory
    --> Cannot open /dev/ttyUSB0: No such file or directory
    --> Cannot open /dev/ttyUSB0: No such file or directory

    Does anyone have any ideas? I'm using the A110 with default linpus install.

    edit: meant linpus not linspire!
     
    Phill, Aug 30, 2008
    #2
    1. Advertisements

  3. Japser

    Japser

    Joined:
    Aug 28, 2008
    Messages:
    267
    Likes Received:
    0
    What is the output of
    Code:
    lsusb
    after you insert the modem?
     
    Japser, Aug 31, 2008
    #3
  4. Japser

    Phill

    Joined:
    Aug 24, 2008
    Messages:
    2
    Likes Received:
    0
    :) fixed it in the end, it turned out it wasn't switching to usbserial, a various combination of shuting down, and using usb_modeswitch seem to have sorted it.
     
    Phill, Sep 1, 2008
    #4
  5. Japser

    Japser

    Joined:
    Aug 28, 2008
    Messages:
    267
    Likes Received:
    0
    Japser, Sep 1, 2008
    #5
  6. Japser

    candep

    Joined:
    Sep 7, 2008
    Messages:
    3
    Likes Received:
    0
    Location:
    Crawley, UK
    This all works up to running wvdial.
    When I run wvdial it says that it cannot open ttyUSB0 because the device or resource is busy.

    Any ideas, anybody?
     
    candep, Sep 7, 2008
    #6
  7. Japser

    Japser

    Joined:
    Aug 28, 2008
    Messages:
    267
    Likes Received:
    0
    sudo wvdial

    ?
     
    Japser, Sep 8, 2008
    #7
  8. Japser

    candep

    Joined:
    Sep 7, 2008
    Messages:
    3
    Likes Received:
    0
    Location:
    Crawley, UK
    Thanks Jasper,

    I got a connection and DNS and secondary DNS addresses but couldn't access anything in the browser.

    More work needed, I guess.

    Thanks again, I'm a lot further forward than I was :D
     
    candep, Sep 8, 2008
    #8
  9. Japser

    tomrowley20287

    Joined:
    Sep 5, 2008
    Messages:
    12
    Likes Received:
    0
    The technique I used with my E220 I think could work with any USB modem.

    In terminal I first wrote "wvdialconf", this set my wvdial to recognise the modem.

    I downloaded wvdial and gnome-ppp, then configured my wvdial settings using the command

    "sudo mousepad wvdial.conf"

    I then copied the conf file details from the Ubuntu User forum web page which lists many many settings from many different providers around the world. If you google it you should be able to find it.

    I was thinking that if the device port was changed to suit your particular modem it should work with any ones. (Mine is ttyUSB0 and I'm using a E220 on Three UK to post this right now)

    If it would help I can try and write a walk through for how I got mine up and running but I'm no linux expert.

    This is the link for the Ubuntu forum, please excuse my non-linkification, I don't know how to do it.

    http://ubuntuforums.org/showthread.php?t=633981

    I found that I had to have the same user name and password in the wvdial.conf as I entered in to Gnome-ppp when I logged on.

    I also have to run Gnome-ppp as root by typing "Sudo gnome-ppp" in to the run command for it to connect.

    I don't know why but it seems my One required gnome-ppp for it to recognise I was connected as using Wvdial alone didn't work.

    Hope this can be of some help.

    Tom
     
    tomrowley20287, Sep 8, 2008
    #9
  10. Japser

    candep

    Joined:
    Sep 7, 2008
    Messages:
    3
    Likes Received:
    0
    Location:
    Crawley, UK
    Finally got online OK :D

    I had to add the DNS address, reported in wvdial, to /etc/resolv.conf. Then went to the browser and all worked fine, but the connection seemed a lot slower than when using windows.
     
    candep, Sep 10, 2008
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.