Black screen, only power LED working

Discussion in 'Modding and Customization' started by Johan H, Feb 12, 2010.

  1. Johan H

    Johan H

    Joined:
    Feb 11, 2010
    Messages:
    4
    Likes Received:
    0
    So, there goes my laptop.

    My trusty Acer Aspire One AOA 150 ZG5 gave up on me during startup. I was in a hurry, and noticing I had left my USB stick in and that the lappy fanatically tried booting from it I jerked it out. Then the computer rebooted and died.

    Now when I push power, nothing happens. The fan starts, stops and starts again eternally, the LED for battery and power shows green, but the screen is not powered, just black and dead. Caps lock and numlock doesn't work, so I know windows isn't running in the background.

    My guess is i fried the BIOS or something when removing the USB during boot. ANy other ideas?

    Now what?? Do I have to blind flash it? I already took the hdd out and made a backup. it's all there.
     
    Johan H, Feb 12, 2010
    #1
    1. Advertisements

  2. Johan H

    stemcell

    Joined:
    Aug 7, 2009
    Messages:
    11
    Likes Received:
    3
    stemcell, Feb 12, 2010
    #2
    1. Advertisements

  3. Johan H

    beyossi

    Joined:
    Feb 12, 2010
    Messages:
    1
    Likes Received:
    0
    Thanks, I faced the same problem and this post helped me!
     
    beyossi, Feb 12, 2010
    #3
  4. Johan H

    Johan H

    Joined:
    Feb 11, 2010
    Messages:
    4
    Likes Received:
    0
    My problem evolves.

    I have tried to flash the BIOS, and I get to the blinking power indicator step. Then nothing at all happens. I am quite familiar with computers and sure I've done everything correctly. Blue LED on the USB stick doesn't blink to indicate activity.

    Hav tried making my Lexar 8GB stick bootable with UNetbootin also.. ..but it should be from before! how do I know for sure if i have the 110 or 150 model - and the same BIOS files? the sticker underneath my AAO is rubbed away..
     
    Johan H, Feb 13, 2010
    #4
  5. Johan H

    RockDoctor

    Joined:
    Aug 21, 2008
    Messages:
    963
    Likes Received:
    0
    Location:
    Minnesota, USA
    SSD: 110
    HDD: 150
     
    RockDoctor, Feb 15, 2010
    #5
  6. Johan H

    Johan H

    Joined:
    Feb 11, 2010
    Messages:
    4
    Likes Received:
    0
    Thus, my 2,5" S-ATA makes my AAO a 150.

    Still no activity in any USB put in during attempted flash. Guess I'll have to contact Acer and tell them I want a new main board. The lappy is two years old - do I get freebies?
     
    Johan H, Feb 18, 2010
    #6
  7. Johan H

    mattyno1

    Joined:
    Feb 6, 2010
    Messages:
    3
    Likes Received:
    0
    Hi,

    Have you tried a different USB stick? as certain sticks have problems booting from BIOS when doing OS installs etc.
    I'm guessing you would have the same problem trying to flash the bios?

    Matt
     
    mattyno1, Mar 10, 2010
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.