battery not holding a charge when powered off

Discussion in 'Laptop Hardware' started by the_case, Nov 13, 2008.

  1. the_case

    the_case

    Joined:
    Aug 26, 2008
    Messages:
    25
    Likes Received:
    0
    A couple times now, I have unplugged the AAO with a full charge and the *power off* - and when I try to use it a day or so later, it won't power on at all - the battery is completely void of a charge.

    Has anyone else seen this problem?
     
    the_case, Nov 13, 2008
    #1
    1. Advertisements

  2. the_case

    slc_silva

    Joined:
    Dec 23, 2008
    Messages:
    4
    Likes Received:
    0
    I also have a similar issue with my battery. I give a full charge on the battery, turn off the A1 and just one day later, when I connect the charger battery plug, the battery light stays yellow for several minutes indicating that the battery has drained the charge. I have other acer laptop (Aspire 5100) and when a repeat the same procedure the battery light turns green almost imediately. Does it mean a battery problem?
    Thanks,
    SLCS
     
    slc_silva, Jan 8, 2009
    #2
    1. Advertisements

  3. the_case

    Darryl

    Joined:
    Sep 1, 2008
    Messages:
    308
    Likes Received:
    0
    Darryl, Jan 8, 2009
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.