Acer Aspire725-0687

Discussion in 'Acer' started by Carrie_Lynn, Aug 22, 2015.

  1. Carrie_Lynn

    Carrie_Lynn

    Joined:
    Aug 22, 2015
    Messages:
    1
    Likes Received:
    0
    My son has an Acer One725-0687 and as soon as I turn this laptop on it says Enter Current Password. I don't know if he put a password in this because he is Autistic, bit he is unable to use this at all. I have tried tapping F1, tried F2, tried F12, and I have tried ALT, DEL, CONTROL all at the same time and still nothing. I put Administrator and also Administrator1 in for the password and I am still getting nowhere. Any suggestions or solutions as I don't have money to purchase him a new one of even as I have read a tool for this either? Someone please help me mAke my little man happy again.
     

    Attached Files:

    Carrie_Lynn, Aug 22, 2015
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.